Author Topic: Volumetric light bleeding with high field of view VR HMD like pimax  (Read 30 times)

detowu

  • Guest
Hello,
we use volumetric light with Unity 2020.3.19f1 and we really like it. There is only one problem.

For our VR experience we use the Pimax VR Headset with its crazy high field of view. We have no problems testing the application in the Unity Editor without the headset connected.
But once we test it live in VR there is a lot of volumetric light bleeding through the walls on the borders of the screen. If we set the field of view of the headset to the low setting, the bleeding is gone.

Is there a way to fix this issue?

I can provide pictures if necessary.

Thanks!

Best,
Dennis
« Last Edit: October 13, 2021, 05:22:06 PM by Kronnect »

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
    • View Profile
Re: Volumetric light bleeding with high field of view VR HMD like pimax
« Reply #1 on: October 13, 2021, 05:23:18 PM »
Hi Dennis,

Yes, please, attach some pictures if you can.
Also, include the settings of the Volumetric Lights component and please specify if you're using multi-pass or single pass stereo.

detowu

  • Guest
Re: Volumetric light bleeding with high field of view VR HMD like pimax
« Reply #2 on: October 13, 2021, 05:36:02 PM »
Wow, thanks for the fast edit and answer!

We use multipass rendering.

https://drive.google.com/file/d/1w_hAQaybvY4_xdnfBOyAAGS80hABtzF_/view?usp=sharing
https://drive.google.com/file/d/1KQvwylLnkNnh7VliK3oRg-Hr2ipuNlN0/view?usp=sharing

Let me know if you have trouble opening the google drive link.

First image are the settings. It's an area light (light itself is disabled).

Second image is a screenshot from the editor, displaying the left eye. You can see the bleeding on the left border of the image (in VR the area around my nose is bleeding the most :D).

Like I said, withoud the headset it's perfect!

Best,
Dennis






Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
    • View Profile
Re: Volumetric light bleeding with high field of view VR HMD like pimax
« Reply #3 on: October 13, 2021, 05:40:28 PM »
Thanks for the additional info, I'll take a look soon.
Cheers!

detowu

  • Guest
Re: Volumetric light bleeding with high field of view VR HMD like pimax
« Reply #4 on: October 13, 2021, 05:55:37 PM »
Thanks!

I just double checked the render method. In fact it is single pass instanced! I will change that and see if it has any effect. Sorry for the confusion! I'll let you know if this solves the issue.

detowu

  • Guest
Re: Volumetric light bleeding with high field of view VR HMD like pimax
« Reply #5 on: October 13, 2021, 06:02:47 PM »
Thanks!

I just double checked the render method. In fact it is single pass instanced! I will change that and see if it has any effect. Sorry for the confusion! I'll let you know if this solves the issue.

No changes wether single pass instanced or multi pass is selected. :(

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
    • View Profile
Re: Volumetric light bleeding with high field of view VR HMD like pimax
« Reply #6 on: October 19, 2021, 05:38:15 PM »
I've tried to reproduce it but it seems the problem has to do with that FOV of being near 200? AND unfortunately I don't have that device so I can't reach that FoV.

Just in case, I have added a new shader option variable that you can enable by editing the Options.hlsl file:

Code
/* Forces world space shadow sampling */
//#define FORCE_WORLD_SPACE_SHADOW_SAMPLING

By uncommeting the above define, the shadow functions will always use the world space position of the ray march position instead of a previously shadowmap-mapped coordinates. My guess is that due to a FoV greater than 180, the shadow coordinates are going nuts. Please grab the beta and give it a try. I'm poking in the dark here as I can't test if this change will solve the issue on your device, so please let me know! (the beta is 4.4.1 for built-in pipeline)