Author Topic: Fog Of War Demo + SetFogAlpha problem  (Read 69 times)

skylinx

  • Newbie
  • *
  • Posts: 2
    • View Profile
Fog Of War Demo + SetFogAlpha problem
« on: September 07, 2021, 08:40:07 AM »
Hello. I downloaded the package yesterday into a brand new project and Fog Of War Hole doesn't work and neither does my object that is supposed to reveal it with SetFogAlpha.

The clouds fog cutting demo scene also doesn't work. The only thing that works to reveal / hide fog of war is the Editor brush tool which does update the texture.

Is there something I'm doing wrong?

I'm using an up to date version of Windows Unity 2018 with the standard pipeline.
I downloaded the most updated version off the asset store into a brand new project.

Here are some screen shots

on camera component


fog hole box




fog of war volume


Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 7262
    • View Profile
Re: Fog Of War Demo + SetFogAlpha problem
« Reply #1 on: September 07, 2021, 11:06:39 AM »
The fog of war hole only works with the main fog script attached to the camera. It'll be improved in next update so you can specify the target fog (so it works on separated fog areas as well).

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 7262
    • View Profile
Re: Fog Of War Demo + SetFogAlpha problem
« Reply #2 on: September 07, 2021, 11:21:39 AM »
Latest version (both in the beta board and on UAS) has now the new Fog of war hole script version plus other minor changes.

skylinx

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Fog Of War Demo + SetFogAlpha problem
« Reply #3 on: September 07, 2021, 11:27:42 PM »
After that update and some tinkering I got it working. Thank you <3

Very great asset

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 7262
    • View Profile
Re: Fog Of War Demo + SetFogAlpha problem
« Reply #4 on: September 08, 2021, 11:19:00 AM »
Great, glad to help. Thanks :)