Author Topic: Multiple chunks not getting updated properly. (Custom voxels still visible)  (Read 138 times)

siddhantsaxena

  • Newbie
  • *
  • Posts: 10
    • View Profile
Hi Ramiro.. I am setting the raw data for multiple chunks in a foreach loop .. and calling ChunkRequestRefresh() and RegisterChunkChanges() for each chunk one by one in loop but its causing some issues and only one chunk is being properly updated.. the other chunks are also deleted partially but the custom voxels in those chunks are still visible (but not interactable).

I did have a look on the ModelPlace() code and it seems that if multiple chunks require refresh then it calls another overload to pass a list of chunks for RegisterChunkChanges(). Is that the right way to do it and will it make any difference?

Link to video example- https://drive.google.com/file/d/1sJ1M4nMfpvRtpusO2cCowjW-b9_6FvZe/view?usp=sharing

I have also added the screenshot of the code that updates the chunks. Please have a look.

UPDATE1: I tried using the other overload of RegisterChunkChanges() and using a list of Voxelchunks initialized using bufferpool. Still the issue is there.

UPDATE2: So I identified that this issue is only coming when we want to update chunk voxels from filled state to empty state. Its working fine for multiple chunks in the case of adding voxels at empty locations.
« Last Edit: August 03, 2021, 12:35:16 PM by siddhantsaxena »

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 7262
    • View Profile
Hi,

Yep, this is fixed now in latest beta.

Regards

siddhantsaxena

  • Newbie
  • *
  • Posts: 10
    • View Profile
Okay cool.. Just to be clear this was happening even with gpu instancing turned off. Anyways will test and let you know if there are any issues

siddhantsaxena

  • Newbie
  • *
  • Posts: 10
    • View Profile
Yes it works perfectly now. Thanks.

Rad

  • Newbie
  • *
  • Posts: 2
    • View Profile
I was having a similar issue to this, but updating to version 10.3.1 from Sept 6th 2021 appears to have fixed chunks freezing and not loading. Great work!

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 7262
    • View Profile
 :)