Author Topic: Volumetric Fog: Error updating to Unity 2020.3.5f1 LTS  (Read 38 times)

CruttMutt

  • Newbie
  • *
  • Posts: 4
    • View Profile
Volumetric Fog: Error updating to Unity 2020.3.5f1 LTS
« on: April 28, 2021, 10:19:25 AM »
Hello!

Big lover of your assets. Pretty much own all of them now. Usually, they work perfectly and they were before I updated my project to Unity 2020.3.5f. I can actually still see the fog fine but I get this error so I would like to get on top of these. Any suggestions on how to overcome it? I have the latest version of volumetric fog and URP all installed correctly. As I said I can use the asset fine seemingly.

This is the error:

Quote
Shader error in 'VolumetricFog2/VolumetricFog2DURP': Couldn't open include file 'Packages/com.unity.render-pipelines.core/ShaderLibrary/Common.hlsl'. at line 52

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 6981
    • View Profile
Re: Volumetric Fog: Error updating to Unity 2020.3.5f1 LTS
« Reply #1 on: April 28, 2021, 10:39:10 AM »
Hey, thanks for your words!
If you can see the fog, then you can ignore that message as any shader simple error would make it pink or prevent it from rendering completely.
That could be a temporary issue while upgrading. Restarting or reimporting the asset should remove that console message.
Best regards


CruttMutt

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Volumetric Fog: Error updating to Unity 2020.3.5f1 LTS
« Reply #2 on: April 28, 2021, 11:18:49 AM »
Thanks heaps! Yes I was just coming back to tell you it just disappeared now but you're so good you beat me to it haha.

Awesome, all working perfect thanks :D