Author Topic: Issues with fog voids and changing camera (cinemachine)  (Read 39 times)

faolad

  • Newbie
  • *
  • Posts: 4
    • View Profile
Issues with fog voids and changing camera (cinemachine)
« on: November 19, 2020, 11:57:56 PM »
I'm having issues with changing the camera with cinemachine and using fog voids. If the distance is long enough the void simply doesn't work. Any Ideas

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 6345
    • View Profile
Re: Issues with fog voids and changing camera (cinemachine)
« Reply #1 on: November 20, 2020, 08:18:17 AM »
Which version of the asset are you using, URP or built-in?
Can you reproduce it without cinemachine, ie, a simple camera and the fog/fog foid?


faolad

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Issues with fog voids and changing camera (cinemachine)
« Reply #2 on: November 21, 2020, 12:28:52 AM »
URP

Kronnect

  • Administrator
  • Hero Member
  • *****
  • Posts: 6345
    • View Profile
Re: Issues with fog voids and changing camera (cinemachine)
« Reply #3 on: November 23, 2020, 08:53:45 AM »
Thank you. I've not been able to reproduce the issue with the URP version. Could you please provide the scene file by pm?

faolad

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Issues with fog voids and changing camera (cinemachine)
« Reply #4 on: November 24, 2020, 01:49:38 AM »
Sure, it will take a while doe. I have been trying to make it work with VolumetricFogAndMist2.VolumetricFogManager.fogVoidManager.TrackFogVoids(), kind of works kind of not